WP-Appboxを更新したらエラーテキストが表示される

サイトでおすすめしたいアプリを手軽にダウンロードができる機能を作ってくれるプラグインWP-Appboxを更新したところ不具合が起こりました。



wp-appboxを更新後に出てきたエラーテキスト

WordPressに表示されたエラーメッセージ

『Warning: filemtime(): stat failed for http://***/wp-content/plugins/wp-appbox/css/styles.min.css in /home/users/2/***/web/wp-content/plugins/wp-appbox/wp-appbox.php on line 940』

 

このようなエラーメッセージが出てきていてWordPressの管理画面とサイトにも反映されていたので早く解決せねばなりません。

原因は書いてある通り『wp-content/plugins/wp-appbox/wp-appbox.php』の中の940行目で何か不具合が起こっていることが書いてあります。

※人によってこの行が変わる可能性もあります。

 

早速見てみますと『filemtime( plugins_url( ‘css/styles.min.css’, __FILE__ ) )』という言記述がどうやらこのプラグインを邪魔しているようでこちらを削除することで問題は解決しました。

手前の記述と区切る『,』も一緒に消し去りましょう。

よって消す記述は

 

,
filemtime( plugins_url( ‘css/styles.min.css’, __FILE__ ) )

 

になります。


いらなくてもエラーが起こっているwp-appbox.phpのバックアップは取っておく

念のため削除前のwp-appbox.phpをバックアップを取っておいてください。

 

もしバックアップを取る前に削除してしまい変なことが起こりましたら一旦プラグインを削除し再ダウンロードを行ってください。

なお再ダウンロードをしてもこのエラーテキストは残ったままなのでもう一度原因となっているテキストを削除してください。